Beta testing for Dashboard Navigation

Hey folks!

We are working on updates to the dashboard navigation experience on the Ather 450X.

We’re looking for beta testers (Gen 3 and Gen 4 owners) to help test the functionality, smoothness of the experience, usability and UI bugs in this update.

Here’s what you will be testing:

  • Revamped live traffic on route experience
  • 2-wheeler-specific maps and routes

What’s our requirement?:

  • Ather 450X with Pro (Gen 4)
  • Ather 450X with active Ather Connect subscription (Gen 3)

When is the beta roll-out?

Between 14th - 19th November, 2023

Fill out the form below to be a part of the beta testing and try these features before anyone else!


Seems like there is an issue in accessing the form

Same error as above.

Finally you’re implementing it! Got tired of following vehicular traffic sometimes when I knew there’s a faster route elsewhere.

Hope this doesn’t really avoid highways and go a longer route just for 2 wheeler friendliness.

Can’t wait to test it, and finally have live traffic be useable. Hope you fix the link soon!


Hey @pratham.shetty and @pdhananjaypatil, the form has been updated. Can you check and let me know if y’all are able to fill the form now?

1 Like

Hey @sirishant! The link has been fixed. Let me know if you’re able to fill in your details. And do let us know what you feel about the new features! :smiley:

1 Like

It’s not fixed yet, getting an error while accessing the link.

Hey Akash, try clicking on the link updated in the post. It should be accessible to all now.

1 Like

Hey Smridhi! The link works now, thanks!

Yup it worked this time thanks @smridhi.kalati

Weird that accessing the link still throws on error on my phone but it worked fine on my PC.

Yup it’s not working on this app tooo but works fine on PC or web It says web page not available.

1 Like

Yeah, same with me

Thanks! It worked fine in PC but had issues accessing the link when i tried in my phone via the app.

try to add “destination reached” at end of the route.Map just zooming out and reseting when you are near point B feels so wierd.


Registered. But link doesn’t work on mobile. I have to use my laptop to get this link working.

Is it available for gen 3 plus owners also?

I think something has to do with beta app…