OTA 4.1.0x

A small update…

1 Like

The Background:

Ather invited a few of the Bangalore and Chennai owners to have a BETA preview of this OTA update. I was excited because this was the first time they were bringing on board the user community to do a BETA test and the tech team was super responsive to every little feedback that we provided.

For those who were part of the 4th Owners meet, this wouldn’t be a surprise. But for others, especially those who use the navigation a lot - this will be a pretty good upgrade - both in terms of functionality and stability.

My Thoughts:

Ather has introduced the “Drop Pin” navigation option. This allows you to point at a location on the map and initiate turn-by-turn instructions. I tried this out a couple of times and it never failed even once. This is especially useful when you get weird addresses that don’t show up in the app search bar or landmarks that just don’t seem to exist where they are meant to be!

The next item was the stability update. We’ve all faced laggy touchscreen or just plain non-responsive touchscreen in the navigation screen. Ather seems to have done a lot of cleanup in this area and for the time I used it, it worked like butter on a non-stick pan! - very smooth screen navigation as we moved around the map as well in the pinch-zoom function.

However, it did seem to lag slightly when navigating through map sections that had not loaded fully - ala the Vodafone network!

On a side note, screen restarts seems to have reduced drastically for me, save for 1 freeze - which was ironically during the Sunday Owners Ride.

And another biggie was the update to the Cloud Sync. The bike now syncs to the cloud every 2 hours or so. This means that your battery percentage is updated on the app every 2 hours from the current “Last screen on” time.

Ofcourse, like always we had a lot of feedback and pointed out areas that can be further improved.

For now, I am appreciative of the team going a step further and involving the larger community into its update/upgrade testing. This helps since we can give them varied feedback as each owner has different expectations, riding style and usage of the bike.

11 Likes

Like @raghav.srinivasan mentioned, I was also thrilled to a part of this OTA Beta group. Wonderful initiative again from Ather. I’ll be happy if my feedback can make even a small difference in improving our product.

It’s been a week for me with this new OTA that’s deployed today for everyone and here are my observations

What’s good

  1. The Navigation Screen responsiveness. It’s very smooth now. Moving around the map, zooming in and out, typing to search a destination have all improved by a big margin. In fact this is how it should’ve been since day 1. Happy that it’s finally happened.

  2. One of the good updates in this OTA is the feature of drop pin in Navigation. Together with the smoother map screen, it is now easy to select a destination from the dashboard itself without having to type.

  3. The best update for me is the auto accept function of route change. I didn’t like that process step of pressing the power button to accept a re-route.

  4. The SOC drop of 2% at every 10% is now gone. This algorithm has been improved and we can now see 99%, 89%, 79%… also which was earlier not seen.

  5. Frequent sync in key off position will now help users in showing more recent state on the phone. I thought this would affect Battery trickle drain in a negative way, but it’s been the opposite so far. the trickle drain has reduced as far as I’ve observed.

What’s not good

  1. Once in the last week, I experienced a hung screen in navigation. Even after moving almost 1kms the navigation didn’t start/move. The screen was was still responsive. I could close navigation and restart navigation and it worked fine after that. I didn’t have to do soft reset or shutdown

What’s not improved / What needs improvement

  1. The indicator autocutoff is still the same…hit or miss

  2. Athergrid points still not sorted by distance to current location

  3. the mystery speed figure of 32kmph is still a mystery!

  4. Typing to search a destination can further improve

Overall, this OTA has stabilised more things than new feature additions. :clap:
Waiting for more feature aadditions in future OTAs (without introducing fresh issues of course)

Closing this post by a long awaited demand…Give me that Dark mode!

6 Likes

What is it ?

Am using the Ather since 1 month and clocked 1k KM. This is the first time my screen freezed when I try to navigate the map after the new OTA update. May be coz of low network. Will try tomorrow again.
Over all map response is bit more smoother than before

1 Like


I didn’t get any update yet.

I think the auto accept function is a feature removal instead of being a new feature. The manual rerouting (by pressing the ignition button) was a useful feature as it notified me with the blue notification that I have gone off route. In more than one instance, it helped me get back on the original route without having to change to a new route which could have been a longer route. After this update, the blue notification does not even appear, so it is not easy to identify that I have gone off route or that it is rerouting. I does say “rerouting” in the top left corner, but that is against the normal white background and doesn’t serve as a clear notification. Additionally, the rerouting takes 5-30 seconds in good network conditions, it is easy to get confused and I would rather not reroute under certain situations. Therefore, in my view, this a poor update as far as the removal of the manual rerouting feature is concerned. I would have been not disappointed with this change if there was at least the blue notification that said something like “rerouting now” (a clearer notification).

3 Likes

why i was missed to be part of that beta testing!!!

:shushing_face::thinking:

Ather can’t afford to have their travelling sales and marketing team stranded in the middle of nowhere, in case of any bugs an glitches.

4 Likes

I dint receive any update :man_shrugging:t2:

The super funny glitch on this update is when the scooter is moving and GPS lock fails. The app shows the scooter in the middle of the ocean

This is momentary and after a bit it resyncs

This is due to flakey GSM network coverage between Sirsi Circle and RPC layout. It has been that way for more than 10 years. I have jumped from Vodafone to BSNL to Airtel and even now a voice call will drop when passing through that stretch

Maybe rather than show random points do some filtring or smoothing

3 Likes

Thanks for that different perspective and use case. :+1:
If I think from your perspective I feel you are right. To me, it (pressing the button) was a distraction from riding.
To each his own… I was thinking how this could be solved.
The option I could think of is a toggle switch “Auto accept reroute” in the settings menu like the follow me home option. Users can turn on turn off this feature based on their personal preference.

3 Likes

Yes even I didn’t get the update

1 Like

The SOC drop of 2% at every 10% is now gone. This algorithm has been improved and we can now see 99%, 89%, 79%… also which was earlier not seen.

This is still an issue. i saw SOC drop from 90 to 88 today post update.

1 Like

Even I have observed the SOC drop from 90 to 88 as well as 80 to 88.

Try restarting (shutdown mode) A450. That fixed issue for me.

Oh ya … if you are talking about the speedometer I am missing not only the 32 but 10, 21, 32, 43 … Etc

1 Like

No it’s the same as previous, still the 9s are missing

It’s not syncing for me for more than 3 hours. And the A450 was in the Network area

After the update screen got freezed for the first time since I bought and did 1K km yesterday. Today screen refused to turn on !

Few observations :
*) Why screen doesn’t show the grids in Chennai?
*) Try any grid @ Chennai and send location to A450, screen will hang and restart on its own
*) As mentioned in the earlier post, 10, 21, 32, 43… Are missing from speedometer (both in map as well as normal screen )
*) While searching a particular place in gmap , if that place is not available, I usually search nearby available place and try to locate the desired location by slightly moving here and there. But how do we do it in our screen ? When you search a place, it hides the PIN.
Searching the place in the dashboard is a nightmare

All in all the update is not worth the release considering the beta testing and all

I have experienced an improvement in accelaration performance after this update. Before the update, I had a nitpicking complaint (which I didn’t report to CC) that my vehicle could only reach 75 Kmph and then it would very slowly gain some speed to reach 80… reaching 89 or 90 was almost impossible because of a lack of clear stretch of road on my usual routes. I couldn’t ever confirm that it was an issue with my vehicle and I had always attributed it to heavier payload or low tire pressure. However, after this update, the vehicle quickly reaches 88 or 89 kmph (breezes past 75) and I can feel the zippiness that I had originally felt during my pre-purchase test rides in July 2019.

This is the first OTA update to my vehicle after getting it delivered on Oct 19 and now, I believe the flashing of this new firmware / update has resolved some bug that had existed with the previous version. I have tested by riding again on my usual routes and I can now overtake fast moving vehicles a lot better than before. The accelaration has improved and I am super happy about it.

I just hope that Ather team has had a chance to analyze this kind of issue with some other owner and that it can be avoided in the future if this was really a software issue that caused marginally degraded performance in the previous firmware.

5 Likes