Navigation using Google Maps on 450X

Guys please share your experiences on Navigation using Google Maps on 450X

5 Likes

Is realtime traffic working on the 450X Navigation as in Google Maps. I believe lot other features aren’t working yet. Is it true or am I missing something???

I think it’s just the API they use i.e. to pull co-ordinates for a place you search and provide you with directions. There is no traffic indicators on the maps like you see on your phone.

However, this makes me wonder if ETA is shown using average speed or after accounting for traffic.:thinking:

You can’t see real time traffic on Ather’s dashboard. Since gmaps isn’t actually tailored for Ather, they have wrapped it in their own interface. Maps info is powered by Google… ETA too. Have compared ETA with gmaps layered with traffic data, it’s the same. But pretty much everything else is Ather.

1 Like

I am facing few problems in Navigation in my 450X.

  • Not able to set Home location form the mobile app…

  • Recent places aren’t working…

  • Favorite places stored on the mobile app doesn’t appear on the vehicle…

  • Maps in Ather are showing a different route when compared to Google Maps…

Anyone who is facing similar problems please share your experiences…

3 Likes

Are you Not able to find where to do it (cause it’s kind of hidden) or is the setting up not working?

As for the rest of the issues - have you got the latest OTA update released a couple of days ago? If yes, tried shutdown and restart?

Have noticed this happen on my 450 but it’s been quite rare. Didn’t make a big difference in terms of route and time for me, don’t know about you. Also you should be able to see alternate routes to choose from.

May be you are right but even for that I called up customer care, they told the product specialist will call you up, which never happened… I am not able to find any such settings in the vehicle manual also… If they are kind of hidden how will the user ever come to know??

Go to profile section (the right most icon on the bottom bar). There you’ll find “Profile” written in green (under your name and above the scooter icon)…Tap that. There you can find option to enter your home location and work location. This is what @arvind_nair meant by “Kind of hidden”

Forum is the better place to know more about your scooter. It’ll have user experience added to it too. It’s probably faster too. I’d recommend to search the forum once before calling CS for such things. For anything that has to be done by Ather, (renewals, payments, pickup, booking stautus etc…) CS is a better place probably.

If you’ve chosen car mode in your phone it’ll be different. The maps of Ather shows that route. Make sure you check that. Also depending on live traffic, the route on your phone might change

5 Likes

Thanks for the info. That was so very much hidden. I would strongly recommend that Ather provides a manual for its software, so as to help it’s customers all use features of the vehicle. Otherwise any user will have to know that such a feature actually exist for him to ask on the forum… If there was a manual just a go through would be enough to know many features that any new user wouldn’t be aware of…

4 Likes

Yes and it would be better in a digital format rather than a printed one. A printed manual will be rendered useless at a future date as the product itself is ever-changing.

1 Like

Chennai: I got the Series-1 recently and I already have the 450 since last October. Here are the issues I have been facing with Navigation/Dashboard/App combo:

(All softwares up to date: 450X, the Ather app and my iOS etc)

  1. When I push a location from my Google Maps -> Ather app -> Dashboard, most of the times it is not received by the Dashboard on the scooter. Not sure if this is due to SIM Card issues. I am bang in the middle of the city. Good network coverage here.

  2. Many times (8/10) when I push a location from Google maps to Ather app, the Ather app says “Location not found” or some other such error. This is even for popular locations like restaurants, cafes etc in Maps. One solution is to SEARCH for that place within Ather app Maps and then push it to the dashboard. This is very annoying and ruins the joy of using navigation. It has become very unreliable and irksome for me.

  3. I am unable to push a random point or LAT LONG coordinates from Google Maps to Ather App Maps. It always says “Location not found”. Why can’t I do this? The whole idea of having navigation on board is to be able to push any location on map in a city and be able to go there. This has happened so many times I have given up now.

  4. I have also had errors in Ather App saying “Location too far”…for places well within central chennai limits. This took me by surprise. The same happened for some places in ECR near Kottivakkam etc. And I was traveling from Velachery.

In summary: Ather team has a lot of bugs to fix and vastly improve the Ather app + Onboard navigation systems. They seem very unreliable, buggy and not dependable. I have fixed a mobile holder to my handle and I use my phone to navigate because of this very unreliable navigation features.

7 Likes

Even I am facing the same issue…

Can anyone also face this same issue of location too far when riding Ather which is not in serviceable area?

Hey Srini, thanks for reporting these issues. We’re aware of some bugs when pushing navigation to the scooter, it’ll be fixed in one of the upcoming OTAs. Do report this through the in-app reporting mechanism so we can make use of the bug reports to speed up the fix.

1 Like

Hi Abhishek, Yes I have reported them via in-app mechanism also.

1 Like

Hi @abhishek.balaji , i have been facing this issue for sometime now. My network disappears most of the times even at home whereas there is 100% coverage in my area.

I have tried to reset the dashboard but to no avail. This also leads to non usable maps. Kindly look into this. ( I am also in the bluetooth beta testing group and after the update i am facing this issue alot. I am not sure if this is a side effect of the update.