Portable charger red light

Even after 1.5 years of getting portable charger, I couldn’t get this to charge even once.

  1. I always used it as backup / last chance
  2. Post covid didn’t drive much at all.

But, In last 2 weeks, I tried 5 places. Everywhere I get red light in portable charger. Long time back, I remember customer care telling me red means voltage or grounding issues. Unable to believe every plug point I tried had grounding issues.

Can some one confirm what red means? Also, any manual for portable charger? I could not find in website or forum.

That’s one of the reasons why they changed the design. The new portable chargers aren’t so senstive to grounding issues. Only our old ones are. Even though that’s the case @Abhishek does all his long rides using this charger itself. He uses a grounding kit. My portable charger doesn’t even work in my own house 🤦. It says some sockets in my house don’t have grounding. Nothing we can do about it. Just have to understand that the portable charger can’t be used everywhere.

1 Like

I have issue with dot charger. It shows orange light. Not sure what is the issue. I have portable charger where no issues(i am using same plug point).

Customer care no response.

1 Like

Really very very worst Customer service in ather bro.some times Customer care executive are can’t pick the calls bro … bro don’t leave it please try to call customer care again … Calls and emails support are not respond bro in Ather…

I spoke with @Abhishek few days back. As usual, he was very helpful and suggested me to try few things, and even offered to come to the place and diagnose the issue. :slight_smile:

Today, I had to go again unplanned. Took the Honeywell extension cable (it has LED to indicate grounding). That glowed green for few plug points and red for few others.

But finally, when I used the portable charger thru the extension cable, inspite of red light, after I plugged in to the vehicle, charger LED turned GREEN and started charging.

Very relieved to have got the portable charger working. Now, I can skip mid-way charging in the Ather grid. :slight_smile: Thanks everyone for your insights and suggestions. :pray:

1 Like