Ather Customer Care new IVR is pathetic!

When called on 7676600900 for an urgent query, it asks to press 1 or 2 from phone’s dial pad. After pressing 1 or 2 it is not going beyond this stage and says "Sorry we have not received any input and thank you for calling Ather & call disconnects . I am not able to speak to customer care executive because of this stupid system. I have tried with other phones with no luck.

You must fix this error ASAP.


True and this is agreed by all owners unanimously.

Ather took a note of this and they are working on it to improve the experience ASAP.

Here is the link of that post by @abhishek.balaji

On a temporary note as a work around if you are not getting connected try pressing the number while it is saying to press number. That worked for me many times when ever I faced this same problem.

So, i am not alone in experiencing that Ather has got itself behind in terms of call center effectiveness. it is natural when a company grows this fast. But am also confident they’ll work out a solution fast…All the best guys !!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.